CPQ_ep_REQUEST wsdl, CPQ_ep_ENDPOINT wsdl “is not semantically valid: error: cos-nonambig:

Integration Activation Failure with Pre-2017 R1 Version of Oracle CPQ Cloud Adapter as a Trigger

Integrations configured with the Oracle CPQ Cloud Adapter as a trigger are failing to activate with the following error. This issue is only occurring in versions of the Oracle CPQ Cloud Adapter prior to 2017 R1.

CPQ_ep_REQUEST wsdl, CPQ_ep_ENDPOINT wsdl "is not semantically valid: error:
cos-nonambig: Content model violates the unique particle attribution rule..
null" and CPQ_ep_REQUEST jca "The JCA dependency is not valid. null"

This issue occurs when you have a repeating element in the CPQ WSDL (for example, _line_bom_parent_id in transactionLineType and ResponsetransactionLineType). Explicitly remove this repeating element from the IAR file. After making this update, the integration can be activated.

This issue does not occur in the 2017 R1 version of the Oracle CPQ Cloud Adapter.

Leave a Reply

Your email address will not be published. Required fields are marked *